Browse Source

Drop python2 support. (#613)

FREEZE-blogpost-2021-01-19
Jelmer Vernooij 1 year ago
committed by GitHub
parent
commit
54f8fb7a7f
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
  1. 2
      .travis.yml
  2. 2
      Makefile
  3. 8
      setup.py
  4. 2
      tox.ini

2
.travis.yml

@ -1,8 +1,6 @@
language: python
matrix:
include:
- python: 2.7
env: TOX_ENV=py27
- python: 3.5
env: TOX_ENV=py35
- python: 3.6

2
Makefile

@ -65,7 +65,7 @@ coverage: $(ISSO_PY_SRC)
nosetests --with-doctest --with-coverage --cover-package=isso --cover-html isso/
test: $($ISSO_PY_SRC)
python setup.py nosetests
python3 setup.py nosetests
clean:
rm -f $(DOCS_MAN_DST) $(DOCS_CSS_DST) $(ISSO_JS_DST)

8
setup.py

@ -8,8 +8,8 @@ from setuptools import setup, find_packages
requires = ['itsdangerous', 'Jinja2', 'misaka>=2.0,<3.0', 'html5lib',
'werkzeug>=1.0', 'bleach', 'flask-caching']
if sys.version_info < (2, 7):
raise SystemExit("Python 2 versions < 2.7 are not supported.")
if sys.version_info < (3, ):
raise SystemExit("Python 2 is not supported.")
elif (3, 0) <= sys.version_info < (3, 4):
raise SystemExit("Python 3 versions < 3.4 are not supported.")
@ -30,16 +30,12 @@ setup(
"Topic :: Internet :: WWW/HTTP :: HTTP Servers",
"Topic :: Internet :: WWW/HTTP :: WSGI :: Application",
"License :: OSI Approved :: MIT License",
"Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6"
"Programming Language :: Python :: 3.7"
"Programming Language :: Python :: 3.8"
],
install_requires=requires,
extras_require={
':python_version=="2.7"': ['ipaddr>=2.1', 'configparser']
},
setup_requires=["cffi>=1.3.0"],
entry_points={
'console_scripts':

2
tox.ini

@ -1,5 +1,5 @@
[tox]
envlist = py27,py35,py36,py37,py38
envlist = py35,py36,py37,py38
[testenv]
deps =

Loading…
Cancel
Save