You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

44 lines
1.3 KiB

#!/usr/bin/env python
# -*- encoding: utf-8 -*-
import sys
from setuptools import setup, find_packages
requires = ['itsdangerous', 'Jinja2', 'misaka>=2.0,<3.0', 'html5lib',
'werkzeug>=1.0', 'bleach', 'flask-caching>=1.9']
if sys.version_info < (3, ):
raise SystemExit("Python 2 is not supported.")
elif (3, 0) <= sys.version_info < (3, 4):
raise SystemExit("Python 3 versions < 3.4 are not supported.")
setup(
name='isso',
version='0.12.3',
author='Martin Zimmermann',
author_email='info@posativ.org',
packages=find_packages(),
include_package_data=True,
zip_safe=False,
url='https://github.com/posativ/isso/',
license='MIT',
description='lightweight Disqus alternative',
classifiers=[
"Development Status :: 4 - Beta",
"Topic :: Internet",
"Topic :: Internet :: WWW/HTTP :: HTTP Servers",
"Topic :: Internet :: WWW/HTTP :: WSGI :: Application",
"License :: OSI Approved :: MIT License",
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6"
"Programming Language :: Python :: 3.7"
"Programming Language :: Python :: 3.8"
],
install_requires=requires,
setup_requires=["cffi>=1.3.0"],
entry_points={
'console_scripts':
['isso = isso:main'],
}
)